среда, 6 ноября 2013 г.

mariadb-client : Зависит: mariadb-client-5.5 (= 5.5.33a+maria-1~saucy) но он не будет установлен

Если при установке mariadb вылезли ошибки:

Пакеты, имеющие неудовлетворённые зависимости:
 mariadb-client : Зависит: mariadb-client-5.5 (= 5.5.33a+maria-1~saucy) но он не будет установлен
 mariadb-server : Зависит: mariadb-server-5.5 (= 5.5.33a+maria-1~saucy) но он не будет установлен



Решение:

Смотрим актуальные версии пакетов:

apt-cache show mysql-common | grep Version
apt-cache show libmysqlclient18 | grep Version


Пример:

ivan@ivan-desktop:~$ apt-cache show mysql-common | grep Version

Version: 5.5.34-0ubuntu0.13.10.1
Version: 5.5.33a+maria-1~saucy
Version: 5.5.32-0ubuntu7

ivan@ivan-desktop:~$ apt-cache show libmysqlclient18 | grep Version

Version: 5.5.34-0ubuntu0.13.10.1
Version: 5.5.33a+maria-1~saucy
Version: 5.5.32-0ubuntu7


Указываем точную версию пакетов, которые хотим установить:

apt-get install mariadb-server-5.5 mariadb-client-5.5 \
 libmysqlclient18=5.5.33a+maria-1~saucy \
 mysql-common=5.5.33a+maria-1~saucy


Нашел тут: http://askubuntu.com/questions/365992/ubuntu-13-10-installing-mariadb

Комментариев нет:

Отправить комментарий